PxPlus User Forum

Twitter Twitter Twitter

Author Topic: PasteFilter cannot be turned off  (Read 339 times)

bbssupport

  • Silver Member
  • ***
  • Posts: 20
    • View Profile
PasteFilter cannot be turned off
« on: December 09, 2020, 07:48:40 PM »
With version 17.1 It appears the new paste filter isn't working correctly - see attached image.
I also cannot turn the pastefilter option off system wide. I've tried:
PRINT 'OPTION'("PasteFilter",0),
PRINT 'OPTION'("PasteFilter","OFF"),
PRINT 'OPTION'("PasteFilter","DISABLE"),
and
SETDEV (0) SET "PasteFilter" TO 0
SETDEV (0) SET "PasteFilter" TO "OFF"
etc

This is causing users must grief. How do we get this fixed?

EVa

  • Silver Member
  • ***
  • Posts: 27
    • View Profile
    • EDIAS
Re: PasteFilter cannot be turned off
« Reply #1 on: December 10, 2020, 05:04:19 AM »
PRINT 'option'("PasteFilter","0"),

works for me.

Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3403
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: PasteFilter cannot be turned off
« Reply #2 on: December 10, 2020, 12:29:39 PM »
By default the PasteFilter is off on ALL input that provide for multiple lines of input and takes the setting from the 'PasteFilter" option for single line inputs (default is on)

When I created a panel here with a multiple line high input and loaded the clipboard using:

CLIP_BOARD WRITE "Line 1"+$0d0a$+"Line 2"+$0909$+"tab"+$0d0a$+"Line3"+$0d0a$

If I then pasted this into the input I got three lines.

However we have noted that for some reason there seems to be a difference in "How" you paste the data.  If you right click and paste the filter seems to always apply, however using the keyboard paste CTRL-V the filter does not unless enabled.

We will see if we can determine the reason for the discrepancy.

bbssupport

  • Silver Member
  • ***
  • Posts: 20
    • View Profile
Re: PasteFilter cannot be turned off
« Reply #3 on: December 10, 2020, 03:54:48 PM »
Hi Mike,

I was using CTRL+V so that might explain why I was experiencing the problem.

I also double checked PRINT 'option'("PasteFilter","0"), this morning to disable system wide and it had no effect. Perhaps this is because all our multi-lines (single line high and multiple lines high) have a visual class applied to them? I cannot see a way to disable the PasteFilter in the visual class or themes options though....