PxPlus User Forum

Twitter Twitter Twitter

Author Topic: pxpsql .ini config on linux  (Read 269 times)

michaelgreer

  • Gold Member
  • ****
  • Posts: 51
    • View Profile
pxpsql .ini config on linux
« on: July 31, 2020, 08:51:16 AM »
I am using pxpsql 6.0 on a linux box, querying data on the same box.  I can easily access normalized tables defined in providex.ddf and .dde, but non-normalized tables as defined in a .ini file are not accessible.  I don't know how to tell the command line what .ini file to use.  Any input appreciated.

Devon Austen

  • Staff
  • Diamond Member
  • *****
  • Posts: 266
  • Don’t Panic
    • View Profile
    • PVX Plus Technologies
Re: pxpsql .ini config on linux
« Reply #1 on: July 31, 2020, 10:05:34 AM »
Use:

-i path
--ini-file path

The path nees to include the name of the INI file i.e. -i /pxplus/data/appdata.ini

The pxpsql command includes a help option -h or --help that lists all of the options including -i

Also the documentation covers this option as well and can be found here https://manual.pvxplus.com/?odbc/pxplus_sql_cmd_line_client.htm
Software Developer for PVX Plus Technologies LTD.

michaelgreer

  • Gold Member
  • ****
  • Posts: 51
    • View Profile
Re: pxpsql .ini config on linux
« Reply #2 on: July 31, 2020, 11:42:06 AM »
Devon,

Perhaps I didn't explain that correctly.  I have configured ODBC into unixODBC.  In that context I don't know how to get an .ini file into use.  Michael

Devon Austen

  • Staff
  • Diamond Member
  • *****
  • Posts: 266
  • Don’t Panic
    • View Profile
    • PVX Plus Technologies
Re: pxpsql .ini config on linux
« Reply #3 on: July 31, 2020, 12:10:19 PM »
If you are trying to setup The PxPlus SQL ODBC driver on Linux you need to let the system know about where the ODBC driver is installed using /etc/odbcinst.ini and then define a DSN in /etc/odbc.ini.

You specify the inifile location as part of the DSN with the connections string keyword IniFile=

Details about setting up a UNIX/Linux PxPlus SQL ODBC driver can be found in the docs here: https://manual.pvxplus.com/?odbc/configuration_procedures/odbc_driver_configuration_unix_linux.htm details on the connection string keywords supproted by the Linux DSN definition can be found here: https://manual.pvxplus.com/?odbc/configuration_procedures/connection_string_keywords.htm
Software Developer for PVX Plus Technologies LTD.

michaelgreer

  • Gold Member
  • ****
  • Posts: 51
    • View Profile
Re: pxpsql .ini config on linux
« Reply #4 on: August 07, 2020, 11:46:42 AM »
Devon,

The Docs don't reference the IniFile option, so that made it hard to ferret out.  Anyway, here is my DSN:
[FACTS]
Driver=PxPlus
Description=FACTS Data
Directory=/infor/facts78
IniFile=/infor/facts78/dict/FACTSDD.INI
Debug=1
LogFile=/tmp/odbc.log

I still get "File is not accessible".  Any other insight? I have worked around this, but would like to get it resolved if possible against future need. - thanks!

Devon Austen

  • Staff
  • Diamond Member
  • *****
  • Posts: 266
  • Don’t Panic
    • View Profile
    • PVX Plus Technologies
Re: pxpsql .ini config on linux
« Reply #5 on: August 07, 2020, 04:39:12 PM »
The IniFile option is mentioned in the docs in the second link I posted on July 31st. The first link also links to that page where it is mentioned.

The supported options in the DSN are the same as the connections string keywords and it is in the connection string keyword document that there are described.

In regards to your file is not accessible error I would suspect that the paths in the FACTSDD.INI may not match what is on the system or may be assuming a prefix is setup. Check your INI file and make sure the paths are pointing to where the files are found.
Software Developer for PVX Plus Technologies LTD.