PxPlus User Forum

Twitter Twitter Twitter

Author Topic: pxp 1600 and Windx Licensing  (Read 231 times)

Lawrence_Leavell

  • Silver Member
  • ***
  • Posts: 35
    • View Profile
pxp 1600 and Windx Licensing
« on: May 15, 2019, 05:30:25 PM »
I just installed Windx pxp 1600 (PXPLUS 2019).
Now, I cannot get logged in before Windx times out.
No way to login? 

PxPlus

  • Administrator
  • Diamond Member
  • *****
  • Posts: 1061
    • View Profile
Re: pxp 1600 and Windx Licensing
« Reply #1 on: May 15, 2019, 05:50:33 PM »
What type of connection are you using?

We just tried both a Simple CS and a SSH (to Centos 6) with the plug in and had no problem.

Lawrence_Leavell

  • Silver Member
  • ***
  • Posts: 35
    • View Profile
Re: pxp 1600 and Windx Licensing
« Reply #2 on: May 15, 2019, 08:13:18 PM »
Telnet and SSH, bot respond in the same manner.
Login occurs, then the line drops in less than 2 seconds.

Lawrence_Leavell

  • Silver Member
  • ***
  • Posts: 35
    • View Profile
Re: pxp 1600 and Windx Licensing
« Reply #3 on: May 15, 2019, 08:46:11 PM »
Also tried Simple C/S connections.
The splash screen appears, then drops almost instantly.
Makes no difference, SSH, telnet, Simple C/S. All behave the same.
Tried from the $HOME directory to avoid running START_UP, still the same. Not a START_UP problem.
If I work fast, I can get "export TERM=ansi" set, then pxplus, before it exits.

EVa

  • Member
  • **
  • Posts: 18
    • View Profile
    • EDIAS
Re: pxp 1600 and Windx Licensing
« Reply #4 on: May 16, 2019, 04:23:27 AM »
There's something not quite right - I installed the Plugin v16 and connected through SSH with our server.  I can start pxplus as xterm without a problem, but when using ansi or winterm, this happens (I added SETTRACE RECORD PGN to ansi/winterm/tty and start.up and created a pvxtrace.log prior to starting PxPlus):

export TERM=ansi
`pwd`/pxplus console.pgm

console.pgm executes this code:

0010 ! console.pgm
0020 SETTRACE RECORD PGN
0030 SET_PARAM 'XT'=0
0040 PRINT "In console mode"
0050 STOP

WindX simply disappears and pvxtrace.log then contains this:

[admin@mail pxplus]$ cat pvxtrace.log
May 16 10:14 [*dev/ansi:25] /apps/pxplus/lib/_dev/ansi
May 16 10:14 [*dev/winterm:15] /apps/pxplus/lib/_dev/winterm
May 16 10:14 [*start.up:25] /apps/pxplus/lib/_start.up
May 16 10:14 [console.pgm:20] /apps/pxplus/console.pgm
May 16 10:14 [console.pgm:40] Sighup received
May 16 10:14 [console.pgm:40] Sighup received - Forcing Auto exit
May 16 10:14 [console.pgm:40] Post SIGHUP read error: count=1
May 16 10:14 [console.pgm:40] Read stdin error count exceeded - Forcing Auto exit
May 16 10:14 [console.pgm:40] Post SIGHUP read error: count=2
May 16 10:14 [console.pgm:40] Read stdin error count exceeded - Forcing Auto exit
May 16 10:14 [<noprog>:65000] Post SIGHUP read error: count=3
May 16 10:14 [<noprog>:65000] Read stdin error count exceeded - Forcing Auto exit
May 16 10:14 [<noprog>:65000] Post SIGHUP read error: count=4
May 16 10:14 [<noprog>:65000] Read stdin error count exceeded - Forcing Auto exit

Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3095
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: pxp 1600 and Windx Licensing
« Reply #5 on: May 16, 2019, 09:30:49 AM »
Please contact us or your re-seller for support on this issue.

They will require additional information such as your serial number to confirm it is both licensed for and activated for PxPlus 2019 (v16).

In the interim we will forward this to our development team to see if they can replicate so that a solution can be found.

Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3095
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: pxp 1600 and Windx Licensing
« Reply #6 on: May 16, 2019, 03:17:57 PM »
Lawrence,

The issue appears to be a result of the facts we included the V15 WindX activation file with the PxPlus 2019 WindX plug-in. 

This would cause the system to disconnect when attempting to connect to a server which itself was not activated for PxPlus 2019.  (i.e It could only connect to a server running PxPlus 2019)

We have since updated the install for the WindX plugin on our web site so please de-install the current one and re-download/install from our web site.

Should you have further trouble, please contact your re-seller for further assistance.