PxPlus User Forum

Twitter Twitter Twitter

Author Topic: Button Don't underline &  (Read 861 times)

bteixeira

  • Silver Member
  • ***
  • Posts: 22
    • View Profile
Button Don't underline &
« on: July 30, 2018, 03:39:36 PM »
I have some buttons where the text is coming from user entered data.  It could have basically any characters including ampersand.  On the font attribute, there is a checkbox for "underline & characters" but this doesn't seem to do anything for buttons.  Short of having to put in a bunch of sub(mytext$,"&","&&") and sub(button.ctl'text$,"&&","&") statements, is there any setting to tell the button to not underline & characters / don't be a hot key button?

Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3368
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: Button Don't underline &
« Reply #1 on: July 30, 2018, 04:48:44 PM »
Where are you seeing this option and what version of PxPlus are you using?

I have checked back to version 9 and not seen the option "underline & characters" for buttons.  It exists for Fonted text but not for buttons.

bteixeira

  • Silver Member
  • ***
  • Posts: 22
    • View Profile
Re: Button Don't underline &
« Reply #2 on: July 31, 2018, 08:50:09 AM »
I see it in all of v14.0, v13.1 and 12.5  I don't see it in v10.  I didn't check any other versions
See attached.

Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3368
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: Button Don't underline &
« Reply #3 on: July 31, 2018, 09:10:10 AM »
Okay -- its in the property sheets setup and not on the main display of properties, on the secondary panel which is why I missed it.

This option doesn't exist for buttons, but the panel to select fonts is when using property sheets is generic and not all options apply to all controls.  We generally use Nomads+ or the revamped Folder style for panel design as it provides more information, each folder set is specifically designed based on the type of control, and in our opinion it is easier to work with.

By default the & always is replaced by an underscore of the following character and there is no way to disable this behaviour.