PxPlus User Forum

Twitter Twitter Twitter

Author Topic: *web/email error message (0/117)  (Read 629 times)

ChrisKCAi

  • Silver Member
  • ***
  • Posts: 24
    • View Profile
Re: *web/email error message (0/117)
« Reply #15 on: May 17, 2021, 02:36:02 PM »
Ken (Mike),

I'm not sure this is 100% the same case but, at the installation where we are encountering this, the server PxPlus is running on is also being used as the SMTP server.
Running V16.20 - Specifying server-name;25 or localhost;25 both failed with the 0/117 error. However local-ipaddr;25 seems to work. HTH.

Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3476
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: *web/email error message (0/117)
« Reply #16 on: May 17, 2021, 02:54:17 PM »
From what you have said, that sounds like the server is having an issue with IPv4 vs IPv6 resolution.

When you specify a server by name the system will attempt to look up the servers IP address which may come back as either IPv4 or IPv6.  What may be happening is we are getting the IPv6 address and not the IPv4 address and that might not be fully resolvable throughout your network (i.e your PC may handle it but all the routers for your internal network may not). 

For example on your system what type of address do you get when you 'ping localhost' IPv4 or IPv6?

Specifying the native IPv4 IP address avoids the issue as throughout the network as only the IPv4 addresses will then be used.

Generally Internet based name look ups come back with an IPv4 address, however its not uncommon for inhouse connections to come back with IPv6 addresses.

You might be able to resolve this issue by adding a IPV4ONLY=1 setting to your INI file in the [Config] section.  This will ignore any IPv6 addresses.

ChrisKCAi

  • Silver Member
  • ***
  • Posts: 24
    • View Profile
Re: *web/email error message (0/117)
« Reply #17 on: May 17, 2021, 04:12:54 PM »
Mike,

Yep, setting IPV4ONLY=1 does the trick and let's me supply the server name to *web/email as opposed to the IP address.

Thanks,

Chris
« Last Edit: May 17, 2021, 04:15:08 PM by ChrisKCAi »

ChrisKCAi

  • Silver Member
  • ***
  • Posts: 24
    • View Profile
Re: *web/email error message (0/117)
« Reply #18 on: May 17, 2021, 04:14:22 PM »
For completeness, as Mike suggested, it is IPV4ONLY=1 (my previous post had originally left out the '4')
« Last Edit: May 17, 2021, 04:18:01 PM by ChrisKCAi »

ksproul

  • Silver Member
  • ***
  • Posts: 42
    • View Profile
Re: *web/email error message (0/117)
« Reply #19 on: May 17, 2021, 07:00:30 PM »
Mike,


I installed a fresh copy of PxPlus 15.10 using the .zip file.  The ADDR didn't error, but opening the tcp port using a tim= value still did.  I ran the original PxPlus installation by launching the pxplus.exe external to our application, meaning no custom startup.  When I did that, the ADDR didn't error either.  So I believe the original installation is good, but maybe our custom start up sets certain parameters that impact the behavior of ADDR.


After reading the recent posts from you and Chris, I tried the ini IPV4ONLY=1 setting, and that also worked for me.  Here's what's confusing though.  The issue only occurs when using a tim= value on the open.  Why does it only fail when using a tim= value on the open?  Is this a windows issue or a PxPlus issue?

Ken Sproul
DPI Information Services, Inc.

Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3476
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: *web/email error message (0/117)
« Reply #20 on: May 17, 2021, 08:18:13 PM »
Not certain why the TIM= causes a problem with IPv6 enabled.  We will look into it however we don't actually do much different when connecting to IPv6.