PxPlus User Forum

Twitter Twitter Twitter

Author Topic: Problems wit Terminalserver 2019 and PvxPlus V17.10  (Read 432 times)

thomas@pruco.at

  • Member
  • **
  • Posts: 13
    • View Profile
Problems wit Terminalserver 2019 and PvxPlus V17.10
« on: May 09, 2021, 06:07:44 AM »
Hello all!

I have a problem with PvX Plus V17.10 and Terminal Server 2019 ...
I keep getting error 65 in many modules.

I just want to show an example here:

Error 65 at:
perform "* winproc.ttl; init_titlebar_controls"; if ...

When I try to display the dump, I also get an error:

[Path to temp \] nomads_dump. [SERVER] .html - File cannot be found.

What am I doing wrong? Why do I get these errors in the terminal server environment?

I use WindX Client...

Please help!

Many Thanks!
« Last Edit: May 09, 2021, 06:13:51 AM by thomas@pruco.at »

EVa

  • Silver Member
  • ***
  • Posts: 32
    • View Profile
    • EDIAS
Re: Problems wit Terminalserver 2019 and PvxPlus V17.10
« Reply #1 on: May 10, 2021, 03:06:21 AM »
Can you add these commands to your start program:

SET_PARAM 'TU'=0; LET  %NOMAD_Turbo_Off=1

Regarding the missing HTML - if you installed v17.10 on top of a previous version, you may want to repair the v17 installation (first stop all processes/services that are running v17).

thomas@pruco.at

  • Member
  • **
  • Posts: 13
    • View Profile
Re: Problems wit Terminalserver 2019 and PvxPlus V17.10
« Reply #2 on: May 11, 2021, 02:14:12 AM »
Hi Eva!

Now i get Error 17...

thomas@pruco.at

  • Member
  • **
  • Posts: 13
    • View Profile
Re: Problems wit Terminalserver 2019 and PvxPlus V17.10
« Reply #3 on: May 11, 2021, 02:31:38 AM »
Hi again!

I forgot to say:

Server= OpenSuse Linux 3.16.7-53-desktop #1 SMP PREEMPT Fri Dec 2 13:19:28 UTC 2016 (7b4a1f9) x86_64 x86_64 x86_64 GNU/Linux

EVa

  • Silver Member
  • ***
  • Posts: 32
    • View Profile
    • EDIAS
Re: Problems wit Terminalserver 2019 and PvxPlus V17.10
« Reply #4 on: May 11, 2021, 03:26:08 AM »
You're getting an error at line 500 in *winproc where it performs *winproc.dsp;DISP_SCRN.  You need to add PASSWORD *,"password" to your start program and open a trace window with 'Log all errors' enabled before you display that panel.  It should tell you on what line in *winproc.dsp the error 17 happens.

Also make sure that your product activation is OK - pxpreg should display two activated products, one for V17 and one for package 7587.

thomas@pruco.at

  • Member
  • **
  • Posts: 13
    • View Profile
Re: Problems wit Terminalserver 2019 and PvxPlus V17.10
« Reply #5 on: May 11, 2021, 04:15:56 AM »
Hi!

Both activations are OK...


Key file: ./lib/ACTIVATE.PVX

Registered to: XXXXXXXXX
        System id: 1637357122
                Class: 664

Professional Serial 680005, 10 users, V17, Registered
   Flags:4010d00a
Package 7587, Registered
   Runtime, Flags:0157000a



I will check your suggestion and get back to you

thomas@pruco.at

  • Member
  • **
  • Posts: 13
    • View Profile
Re: Problems wit Terminalserver 2019 and PvxPlus V17.10
« Reply #6 on: May 11, 2021, 04:32:14 AM »
Hi again (and again and again :-))

I have started Only WindX without any startprogram...
See Error attached.

I cannot open Trace Window or any other Debugging windows.
If i will open, nothing happens...

Hmmm....

thomas@pruco.at

  • Member
  • **
  • Posts: 13
    • View Profile
Re: Problems wit Terminalserver 2019 and PvxPlus V17.10
« Reply #7 on: May 11, 2021, 04:34:57 AM »
Dump attached

EVa

  • Silver Member
  • ***
  • Posts: 32
    • View Profile
    • EDIAS
Re: Problems wit Terminalserver 2019 and PvxPlus V17.10
« Reply #8 on: May 11, 2021, 05:34:04 AM »
Can you check if you have a *plus/dll/pluslib_base.dll file (on the WindX side) ?  If not, you need to download the v17.10 PxPlus Windows ZIP download, extract that file and copy it to your Windx lib/_plus/dll folder.  Then restart WindX and try again.

Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3476
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: Problems wit Terminalserver 2019 and PvxPlus V17.10
« Reply #9 on: May 11, 2021, 09:09:20 PM »
Make sure you are using the same WindX version as PxPlus version as the system will need access to a number of images embedded both withing the EXE and image DLLs that come with the version.

thomas@pruco.at

  • Member
  • **
  • Posts: 13
    • View Profile
Re: Problems wit Terminalserver 2019 and PvxPlus V17.10
« Reply #10 on: May 12, 2021, 03:36:57 AM »
Hi all, Hello Mike!

I don't know why, but i uninstalled the WindX Version (17.10.000 Update1) completely from our System, then i reinstalled again and now all seems to be OK.

Thank You for supporting and have a nice Day!

Best regards
Thomas

thomas@pruco.at

  • Member
  • **
  • Posts: 13
    • View Profile
Re: Problems wit Terminalserver 2019 and PvxPlus V17.10
« Reply #11 on: May 12, 2021, 03:53:48 AM »
Once more (Sorry...)

IT's not possible to open Command Mode Window or the other debugging features...
If i will start one, nothing happens...
No Window is appearing.

Suggestions?


Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3476
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: Problems wit Terminalserver 2019 and PvxPlus V17.10
« Reply #12 on: May 12, 2021, 11:07:56 AM »
When using WindX you need to use the system menu to launch the debug windows (ALT-SPACE > Debugging Environment). 

If this option is not present then Debugging on WindX has not been enabled through the DEBUG=1 option in the WindX INI file.

thomas@pruco.at

  • Member
  • **
  • Posts: 13
    • View Profile
Re: Problems wit Terminalserver 2019 and PvxPlus V17.10
« Reply #13 on: May 14, 2021, 04:02:47 AM »
Hi Mike!

Thank you, that was the trick :-)
Wrong GPO...

Best regards
Thomas