Critical/Reproduceable crash specific to PXP version 16.2 when creating JSON

Started by Loren Doornek, September 23, 2022, 08:49:47 PM

Previous topic - Next topic

Loren Doornek

The following code will instantly crash (end the session) on all of our installations of PXP version 16.2.  The session will die at line 20.

0010 LET ja$["id"]="123",withnum$="id"
0020 LET json$=DIM(LIST EDIT ja${ALL} WITH NUM(withnum$))

We use similar logic extensively on every other version of PXP, from version 11 through 17.  The code even works correctly on PXP Version 16.1.  The problem is specific to version 16.2, and is somehow related to the "WITH NUM" functionality.  (Removing the WITH NUM functionality allows the code to execute successfully).

We're looking into upgrading our clients that are currently using PXP 16.2, since JSON is used extensively with our web integrations.  However, if there is an easier solution, I'd love to hear it!

Also, I'd be curious if anyone with access to an installation of PXP 16.2 could test this code, so that we can determine if it's something specific to our installation routines.  Our installations are all on Linux servers, generally Centos or RedHat.

Thanks in advance for any suggestions or feedback!

Mike King

We just tried this on Redhat and didn't get an error.

PxPlus-2019 Web (Ver:16.20/UNIX-Linux-RedHat) Serno:1620-664-xxxxxxx
(c) Copyright 2005-2018 PVX Plus Technologies Ltd. (All rights reserved)
-}0010 LET ja$["id"]="123",withnum$="id"
-;0020 LET json$=DIM(LIST EDIT ja${ALL} WITH NUM(withnum$))

Tried the same on Windows and got the same result.

There have however been a number of enhancements and change the JSON engine in newer versions of PxPlus so we would suggest you upgrade.
Mike King
President - BBSysco Consulting

Loren Doornek

Thanks for testing this, Mike! 

I just tried it on four other clients using 16.2, and all had the same issue, so there's apparently something wrong with our installation package.  We may need to rebuild our install package with the latest download of 16.2, but upgrading to a newer version is a lot simpler.

Mike King

What OS are you running on?

It could be a specific issue with a specific OS build.
Mike King
President - BBSysco Consulting

Loren Doornek

It's several different OS versions.  I just tested 4 clients again, and checked their system-release file, and they were all different.

CentOS release 6.8 (Final)
Red Hat Enterprise Linux Server release 6.10 (Santiago)
CentOS release 6.3 (Final)
CentOS Linux release 7.9.2009 (Core)