PxPlus User Forum

Twitter Twitter Twitter

Author Topic: Big problem with *web/Email  (Read 183 times)

thomas@pruco.at

  • Member
  • **
  • Posts: 13
    • View Profile
Big problem with *web/Email
« on: June 15, 2021, 11:52:22 AM »
Hallo all!

Please help me!

PVXPlus PRO V17, SuSE 13.2

I will send a test E-Mail to our exchange but i get an error:

I don't know why it will use ssl...

Here, what i do:

-}goto test
-}run
CALL "*web/email","e-beleg@halek.at","","thomas@pruco.at","","","Test Please Ign
ore","Hi this is a test from PxPlus."+$0D0A$+"Hello World","","N","halek-exchg"+
";"+"25"+";"+""+";"+"",0,-1,"",1,errormsg$,"",savedfilename$
ERROR: Sending to SMTP Server Failed: (99): Writing to SMTP Server: halek-exchg;
25 Failed. (99/175).
MSG(-1)=Could not locate entry point 'TLS_client_method' in libssl library.
Likely an incompatible SSL Interface. (err/ret=0/0)
MSG(-1): Could not locate entry point 'TLS_client_method' in libssl library.
Likely an incompatible SSL Interface. (err/ret=0/0)
10000 ESCAPE
1}
1}
1}open(10)"[TCP]halek-exchg;25"
1}read record(10)x$
1}print x$
220 HALEK-EXCHG.halek.local Microsoft ESMTP MAIL Service ready at Tue, 15 Jun 20
21 17:37:15 +0200
1}end
-}
-}ls -l /lib/libssl*
libssl.so                  389,864 Bytes     2016-09-23 20:52:00
libssl.so.1.0.0            389,864 Bytes     2016-09-23 20:52:00
-}ls -l /lib64/libssl*
libssl.so                  425,240 Bytes     2016-09-23 20:44:13
libssl.so.1.0.0            425,240 Bytes     2016-09-23 20:44:13
-}


So what can i do?
I'm confused...

Thank You!

Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3496
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: Big problem with *web/Email
« Reply #1 on: June 15, 2021, 02:07:41 PM »
Which v17 Suse download did you use?

Please note, only Suse 11.3 and 15.1 have downloads.  The build done for 11.3 is based on openssl 1.0.0 whereas the 15.1 download was built using openssl 1.1.0