PxPlus User Forum

Twitter Twitter Twitter

Author Topic: SSH Conection Keep alive  (Read 556 times)

JimGwynn

  • Member
  • **
  • Posts: 16
    • View Profile
SSH Conection Keep alive
« on: March 19, 2020, 12:00:25 PM »
All - Need some emergency help
As we have moved all of our users to home workers we are experiencing excessive timeouts
Is there anyway using the SSH connection in the client launcher to set the Putty keep alive parameters?

Thanks

Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3417
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: SSH Conection Keep alive
« Reply #1 on: March 19, 2020, 12:21:18 PM »
What you can do is create a putty session and save it then instead of providing the host name to WindX provide the session name.

For example if the host is ourhost.yourdomain.com, then create a session in putty that will connect to that host and save it, for example, as myhost.  Now in the WindX SSH host name field specify myhost instead of the server name.

You can also use this to provide SSH keys and pre-define the userid/password.

JimGwynn

  • Member
  • **
  • Posts: 16
    • View Profile
Re: SSH Conection Keep alive
« Reply #2 on: March 19, 2020, 12:30:22 PM »
Mike - When I do that I get this message

User Override
UserID has been overridden by Session 'TEST'

JimGwynn

  • Member
  • **
  • Posts: 16
    • View Profile
Re: SSH Conection Keep alive
« Reply #3 on: March 19, 2020, 12:37:03 PM »
Here is a screen shot of my config

JimGwynn

  • Member
  • **
  • Posts: 16
    • View Profile
Re: SSH Conection Keep alive
« Reply #4 on: March 19, 2020, 12:40:10 PM »
Here is a better image

Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3417
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: SSH Conection Keep alive
« Reply #5 on: March 19, 2020, 01:37:27 PM »
This is because the system will use the userid from the session definition.  Set your userid on the session and resave then don't provide a user or password on the WindX screen.

JimGwynn

  • Member
  • **
  • Posts: 16
    • View Profile
Re: SSH Conection Keep alive
« Reply #6 on: March 19, 2020, 04:34:55 PM »
Thanks Mike that did work

For anyone else that may have a similar issue - Here is what we found and what works

We setup SSH access through a Network Load Balancer in AWS. This NLB has a fixed session timeout of 350s

What we did to solve this was Set the +A system parameter to 1.  By default this is set to 10 min causing the NLB to timeout sessions.

With this we did not need to touch any of the the users putty settings.

Thanks Again.