PxPlus User Forum

Twitter Twitter Twitter

Author Topic: New Query not pre-loading  (Read 1473 times)

edjack

  • Silver Member
  • ***
  • Posts: 40
  • Computerease
    • View Profile
New Query not pre-loading
« on: July 10, 2018, 12:54:45 PM »
We have tried the new query with several applications and found it does not behave properly.
Using version 13.1
If the file has many records and the query is set to pre-load data... most times the data will pre-load but you cannot re-sort by clicking on a column title.
The only solution we have found so far is to exit the query and run it again. Usually the second time it works as expected.
This happens with various files and applications.
We have now reverted back to the old query, which seems to work fine.
Has anyone else experienced this? Or should I be looking for a solution?

Ed Jack
Computerease

Jane Raymond

  • Staff
  • Diamond Member
  • *****
  • Posts: 260
    • View Profile
    • PVX Plus Technologies
Re: New Query not pre-loading
« Reply #1 on: July 10, 2018, 03:29:34 PM »
The new query does not actually pre-load data. This is an option setting for the classic query to allow column sorting. The new query will either load-on-demand or background load. The issue which you may be encountering is that you can only sort on a column when all the data has been loaded into the query listbox. With the classic query, there was no display until all the records were read, so when you clicked on the column header, the sort occurred. With the new query, records are displayed before they have all been read, so there could be a wait while records are being loaded before the sort could happen.




 
Jane Raymond
Software Developer
PVX Plus Technologies Ltd.

edjack

  • Silver Member
  • ***
  • Posts: 40
  • Computerease
    • View Profile
Re: New Query not pre-loading
« Reply #2 on: July 11, 2018, 01:22:26 PM »
The new query does not actually pre-load data. This is an option setting for the classic query to allow column sorting. The new query will either load-on-demand or background load. The issue which you may be encountering is that you can only sort on a column when all the data has been loaded into the query listbox. With the classic query, there was no display until all the records were read, so when you clicked on the column header, the sort occurred. With the new query, records are displayed before they have all been read, so there could be a wait while records are being loaded before the sort could happen.

I was missing the "Loeading.." message that is on the classic query.

Would it be practical to put a loading message on the new query... So the user is aware that the records are still being loaded?

Ed Jack
Computerease

Jane Raymond

  • Staff
  • Diamond Member
  • *****
  • Posts: 260
    • View Profile
    • PVX Plus Technologies
Re: New Query not pre-loading
« Reply #3 on: July 12, 2018, 08:52:31 AM »
It does not make sense to display a 'Loading' message when load-on-demand is being used, as pages are only loaded when needed. A message is displayed, however, when you click on a column to sort and all the records have not yet been loaded. I'm just not sure what version that occurs in.
Jane Raymond
Software Developer
PVX Plus Technologies Ltd.

edjack

  • Silver Member
  • ***
  • Posts: 40
  • Computerease
    • View Profile
Re: New Query not pre-loading
« Reply #4 on: July 12, 2018, 09:26:38 AM »
I may have had a corrupt query... i re-defined it and it loads as expected now and very fast.
Ed Jack
Computerease