PxPlus User Forum

Twitter Twitter Twitter

Author Topic: AutoCompName in Grid  (Read 1015 times)

jdegrendele

  • Member
  • **
  • Posts: 12
    • View Profile
AutoCompName in Grid
« on: March 28, 2019, 06:17:58 PM »
Trying to use AutoCompName property in presets of a grid.  The Column (Number/Name) is greyed out and set to a value of zero.  I am unable to assign which column I would like for the property to be associated with.  Providex version 14.1.

Susan Cryderman

  • Staff
  • Gold Member
  • *****
  • Posts: 50
    • View Profile
    • PVX Plus Technologies Ltd.
Re: AutoCompName in Grid
« Reply #1 on: March 29, 2019, 09:24:26 AM »
Thanks for reporting this issue.  It appears that grid presets is coded to assume that this property applies to the entire grid rather than cell by cell.

We have re-worked some of this code for our upcoming release and will ensure that this is corrected going forward.

In the meantime, we have created a support ticket for which you should be receiving an email message in order to correct the issue on your current version.

Susan Cryderman

  • Staff
  • Gold Member
  • *****
  • Posts: 50
    • View Profile
    • PVX Plus Technologies Ltd.
Re: AutoCompName in Grid
« Reply #2 on: March 29, 2019, 03:16:54 PM »
In case anyone else is having the same issue - the fix is a one line change to either the *winold/control.grd program (if using NOMADS+ or Folder Style) or the *win/proppresets program if using Property Sheets.

If you load either program in an editor - you should see that line 163 defines a variable called prop_both$ that is a long list of properties.

The AUTOCOMPNAME property needs to be added to this list.  It does not really matter where - but they are currently alphabetical so we can add it as follows;

prop_both$="ALIGN,AUTOCOMPNAME,AUTOVALUE, ...

(don't forget the comma afterward).


This should allow both the column and row values to be specified.