PxPlus User Forum

Twitter Twitter Twitter

Author Topic: Problems with Report viewer  (Read 255 times)

HendersonS

  • Silver Member
  • ***
  • Posts: 28
    • View Profile
Problems with Report viewer
« on: March 17, 2021, 04:19:51 PM »
Hello everyone, recently we have a strange message from the report viewer when it is in the tray to print some reports (see attached image), after this message the viewer closes, does anyone know why this happens?

Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3462
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: Problems with Report viewer
« Reply #1 on: March 18, 2021, 09:46:49 PM »
Not certain what you mean by 'in the tray'.

Also what version PxPlus and Windows are you running? With/without WindX?

HendersonS

  • Silver Member
  • ***
  • Posts: 28
    • View Profile
Re: Problems with Report viewer
« Reply #2 on: March 19, 2021, 04:12:53 PM »
hi mike,

sorry i mean when you send something to print.

we use Windows 10 with windx, pxplus version is 13.10

Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3462
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: Problems with Report viewer
« Reply #3 on: March 19, 2021, 05:11:59 PM »
We searched for the source of this message and have not been successful so far. 

Do you know which report viewer you are using?

Are you opening *VIEWER*, or *pdf*;view? 
Also if using WindX are you opening using a [wdx] or [lcl] prefix which would route the output to the workstation?

HendersonS

  • Silver Member
  • ***
  • Posts: 28
    • View Profile
Re: Problems with Report viewer
« Reply #4 on: March 19, 2021, 05:28:43 PM »
this is the opening routine
Code: [Select]
LET CHAN=UNT; OPEN (CHAN)"[wdx]"+"*viewer*;suppresswatermarks;orientation=landscape"