PxPlus User Forum

Twitter Twitter Twitter

Author Topic: Event within grid not triggering  (Read 1272 times)

Zereliq

  • Member
  • **
  • Posts: 16
    • View Profile
Re: Event within grid not triggering
« Reply #15 on: November 29, 2022, 03:10:34 AM »
Hey Mike,

This seems to have changed some things positively, but still seem to have some odd behaviour,
It does now work when focussed on items like listbox and input, but still resets it when shifting focus from the changing grid-item to a button or link.
Maybe that still needs a touchup but other than that better than before!




Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3713
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: Event within grid not triggering
« Reply #16 on: November 29, 2022, 01:42:20 PM »
Are you changing the cell with focus to a button/link or changing another cell on the same row?

Also how are you changing the cell type?  If you are simply hiding one control in the cell and then making another visible, then the system would have no idea as to where to send focus since the control with focus still exists -- its just hidden.

The logic is designed such that if the control with focus gets deleted and re-created we put focus back on the control.  But if the control still exists and is hidden, then the system will try to put focus back on it.  So if you hide an input field in a grid cell and create (or make visible) a button to replace it, the system has no way to know where to send focus.

Zereliq

  • Member
  • **
  • Posts: 16
    • View Profile
Re: Event within grid not triggering
« Reply #17 on: November 30, 2022, 02:53:10 AM »
Hey Mike,

I have attached a gif that should show what i am talking about.

Whenever I change the cell content and tab once putting the tab focus from the changing cell to the
Code: [Select]
[link] in the next cell it doesn't keep the focus on set item,
but whenever i change the cell content and tab twice putting the tab focus from the changing cell to a
Code: [Select]
[list] two cells over it does work correctly.

As you can see, The focus does stay on the list item, but doesnt on the link (and or button has the same behaviour)

Thanks again for taking the time to look into this  ;D

Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3713
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: Event within grid not triggering
« Reply #18 on: December 01, 2022, 09:32:26 AM »
For others following along this thread.  We forwarded a minor change to the binding logic that addressed this loss of focus issue on buttons/links that reload the grid they are part of.  The change will included in our next update.