PxPlus User Forum

Twitter Twitter Twitter

Author Topic: Auto-Complete not setting kno  (Read 1262 times)

James Zukowski

  • Diamond Member
  • *****
  • Posts: 303
    • View Profile
Auto-Complete not setting kno
« on: November 02, 2023, 10:00:28 AM »
We've got a file with keys defined as:

External key size ............: 6
Alt. key 1 ...................: [7:1:10]+[1:1:6]
Alt. key 2 ...................: [12:1:8]+[1:1:6]
Alt. key 3 ...................: ["ADDRESS1":3:1:30]

When creating an Auto-Complete definition for Alt. key 3, there seems to be a problem. When I set the "Key Name/Number" field to 3, all is well. But when I set it to "ADDRESS1" (with or without quotes), the auto-complete doesn't work; it operates as a standard multi-line.

Is there something I'm missing?

(PxPlus v15.1 on Linux)
« Last Edit: November 02, 2023, 11:31:26 AM by James Zukowski »
James Zukowski
Sr. Developer - J&E

BRAND>SAFWAY
Brand Industrial Services

James Zukowski

  • Diamond Member
  • *****
  • Posts: 303
    • View Profile
Re: Auto-Complete not setting kno
« Reply #1 on: November 09, 2023, 11:48:55 AM »
Has anyone encountered this before?
James Zukowski
Sr. Developer - J&E

BRAND>SAFWAY
Brand Industrial Services

Jane Raymond

  • Staff
  • Diamond Member
  • *****
  • Posts: 280
    • View Profile
    • PVX Plus Technologies
Re: Auto-Complete not setting kno
« Reply #2 on: November 09, 2023, 01:59:09 PM »
James,
Based on what you described, I could not duplicate this issue, so we will need more information to proceed. You should create an issue on the helpdesk:
https://helpdesk.pvxplus.com
It will be easier to exchange information there and track the issue.
Jane Raymond
Software Developer
PVX Plus Technologies Ltd.