PxPlus User Forum

Twitter Twitter Twitter

Author Topic: Error 15 in *plus/web/request  (Read 275 times)

michaelgreer

  • Diamond Member
  • *****
  • Posts: 107
    • View Profile
Error 15 in *plus/web/request
« on: September 27, 2022, 12:23:36 PM »
I have a customer running pxplus 12.50 on linux.  Linux is set to support TLS 1.2.  On a call to request I get the open to the web site for the API I am trying to access, but when PxPlus tries to write the body (r$) I am getting an error 15.  Ideas?  Thanks!

Devon Austen

  • Staff
  • Diamond Member
  • *****
  • Posts: 335
  • Don’t Panic
    • View Profile
    • PVX Plus Technologies
Re: Error 15 in *plus/web/request
« Reply #1 on: September 27, 2022, 01:52:25 PM »
I just tested 12.50 on CentOS 6 and I could use

Code: [Select]
call "*plus/web/request","https://tls-v1-2.badssl.com:1012/","",result$,rhdr$
The rhdr$ result indicates it connected successfully via TLS 1.2.

Maybe the looking at the error message from the OS will help. When you get the error do a

Code: [Select]
print  MSG(-1)
Software Developer for PVX Plus Technologies LTD.

michaelgreer

  • Diamond Member
  • *****
  • Posts: 107
    • View Profile
Re: Error 15 in *plus/web/request
« Reply #2 on: September 27, 2022, 03:09:05 PM »
Thanks Devon.  I too can successfully make the call you used.  I get a lengthy response but it does indicate "tls-v1-2".

On my call I get:

[TCP][Sockets]Error[2]:No such file or directory (5:<Unk>)

I am able to make a successful call from my PC running windows 10 and using PxPlus v 19.00

Devon Austen

  • Staff
  • Diamond Member
  • *****
  • Posts: 335
  • Don’t Panic
    • View Profile
    • PVX Plus Technologies
Re: Error 15 in *plus/web/request
« Reply #3 on: September 27, 2022, 04:18:29 PM »
This is just a guess but it sounds like what you are trying to access for your original test is not accessible from your machine. I would check firewall and to make sure you are on the correct network to access the resouce.
Software Developer for PVX Plus Technologies LTD.

michaelgreer

  • Diamond Member
  • *****
  • Posts: 107
    • View Profile
Re: Error 15 in *plus/web/request
« Reply #4 on: September 29, 2022, 11:49:11 AM »
Devon,

I went ahead and installed version 18 (dev suite 2021) in demo mode. Full communication with no issues.  I will work with the customer to upgrade or add on a new license. Must be something deep down in the implementation at 12.5 that is still causing an issue. - Michael

Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3701
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: Error 15 in *plus/web/request
« Reply #5 on: September 29, 2022, 01:54:13 PM »
This sounds like there may have been a compatibility issue between the version of PxPlus you are using and the Linux OS.

What PxPlus download did you use for your 12.50 install and what Linux OS version are you running?