PxPlus User Forum

Twitter Twitter Twitter

Author Topic: How to disable blink?  (Read 781 times)

Ned L

  • Member
  • **
  • Posts: 18
    • View Profile
How to disable blink?
« on: November 19, 2019, 12:37:35 PM »
My application, written in PxPlus (not Nomads) occasionally uses 'BB' and 'EB' to highlight various fields.
Many, many years ago we set 'BB' to appear in red using
   1116 VIDEO_PALETTE INDEXED READ TEMP$
   1118 LET TEMP$(17,8)=$0101010101010101$; REM " 'BB' = Red
   1120 VIDEO_PALETTE INDEXED TEMP$; REM "Save change
so these fields both blinked and appeared with red text.

I have a client who likes the red, but doesn't want the text to blink.
Is there a method to globally turn off the blink, without affecting the color?
I've tried
MNEMONIC 'BB'=""
and
MNEMONIC 'BB'=$00$
but those aren't accepted.

I've tried
?'OPTION'("BlinkTime",0)
but that seems to make the text disappear completely.

Maybe this is a matter of modifying the terminal driver in *dev
But, frankly, I'm not sure which terminal driver I'm using.
I'm starting PxPlus with
  "\\spsrds\c$\PVX Plus Technologies\PxPlus 2019 Upd 1\pxplus.exe" -NR -SZ=8000  m:\_QAP\CP\OP4MZA"
running on a Windows server.  What determines which terminal emulation setup routine is used?  If I knew that, would it just be a matter of REM'ing out the
MNEMONIC 'BB'=
statement?

Thanks in advance for any assistance you can provide.
« Last Edit: November 19, 2019, 12:49:33 PM by Ned L »

Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3492
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: How to disable blink?
« Reply #1 on: November 20, 2019, 10:15:49 AM »
There is no way to disable the blinking.

We would suggest you try perhaps replacing all ‘BB’ with ‘BR’ and ‘EB’ with ‘ER’ which will do a reverse video — or perhaps to ‘RED’ and ‘RM’ respectively.

The bulk edit utility should be able to do this quickly for you.

Ned L

  • Member
  • **
  • Posts: 18
    • View Profile
Re: How to disable blink?
« Reply #2 on: November 21, 2019, 05:48:10 PM »
Thanks, Mike!
(No wonder I couldn't figure out how to do it!)