winprt

Started by Sam Nehama, March 21, 2024, 02:26:24 PM

Previous topic - Next topic

Sam Nehama

I'm trying to set up a printer specifically for printing checks.  We had modified the hplaser device driver utility to print the checks via a network connection, and this has worked for many years.  The check printer has now been moved out of the office to someone's home, and they only have a VPN connection to the server (Winhost/Winslave) and a USB printer.  I've tried *windev*, and it prints nothing.  *winprt* does print to the USB printer, but it seems to ignore the modified hplaser device driver utility.  For check to line up properly it's important that the codes are sent to the printer from the modified device driver.  Any idea on what I'm doing wrong?

Thanks,
Sam

michaelgreer

Sam - I'd be interested to know what happens when you enter: open(hfn)"[wdx]"+"*windev*
On that workstation.  This might tell you what issue you are facing. Beyond that, for this use you will need to have the printer configured with a generic/text only driver.  *winprt* interacts (I believe) with the windows print driver.  I don't think your pvx driver is being ignored so much as overridden.

Jeffrey Ferreira

Hi Sam,

We've had a similar problem before.
winprt works fine (using windows print driver)
windev does not work
even though i'm pretty certain windev does not use the windows print driver, we had to change our windows print driver to an HP Universal Driver in order to print pcl or any of those mnemonics you see inside the *dev\hplaser. I dont know why that is but i would give it a try.

Jeff

Sam Nehama

Mike,

I set up a generic/text only printer but nothing ever prints - the lights light up, but no printing.
I also tried using the command you indicated but same thing - lights light up, no printing, no error messages.

Jeff,

I did try the universal driver but it seemed to indicate this needs to be a network printer - and it also indicated it will not work on an MFP printer, which this is.

Thanks,
Sam