Main Board > Programming

REMOVE failing if record not EXTRACTed


James Zukowski:
We have a multi-keyed file with 2 keys; the first has 8 components, the second has 9. When we tried to manually remove an entry, the REMOVE wouldn't work unless we EXTRACTed the record. It turns out that the primary key had a null key field element. I wouldn't think that should cause it to require an EXTRACT to be REMOVEd. (BTW, the file has almost 14M records.)
Any insights?

Mike King:
You might want to submit this to our helpdesk so someone in support can have a look at it.

They would probably need the type of error you are getting (error code/message) the file definition from FIN(nnn, "FILE_CREATE"), and what the key was you used and how you created it.

James Zukowski:
Tried to re-create the problem, but couldn't. When I manually write the file and REMOVE, it's all OK. Here's the create string:

KEYED "PFILE",[1:1:4]+[2:1:8]+[3:1:5]+[4:1:5]+[5:1:5]+[6:1:2]+[7:1:2]+[8:1:2],[1:1:4]+[2:1:8]+[15:1:4]+[3:1:5]+[4:1:5]+[5:1:5]+[6:1:2]+[7:1:2]+[8:1:2],0,-1024,BSZ=8,OPT="2",SEP=$8A$

There are 14M records in the EFF file, totaling 9GB. It's been around for YEARS, and just threw this one out. I thought it might be a file structure problem, so I ran a File Utility Check on problems.

Strange occurrence. If it happens again, we'll see about the helpdesk ticket.

Thanks for the consideration.


[0] Message Index

Go to full version