PxPlus User Forum

Twitter Twitter Twitter

Author Topic: pvxplus 2023 - ubuntu 22 openssl not working? [SOLVED]  (Read 1794 times)

martinp

  • Silver Member
  • ***
  • Posts: 38
    • View Profile
pvxplus 2023 - ubuntu 22 openssl not working? [SOLVED]
« on: May 24, 2023, 04:19:11 PM »
Hi thanks for releasing pvxplus 2023.

No luck with Ubuntu 22 and openssl still I need to assign:

export PXP_SSL_LIB=/usr/local/lib/libssl.so.1.1
export PXP_CRYPTO_LIB=/usr/local/lib/libcrypto.so.1.1

And I now am getting a new error:

Could not locate entry point 'OSSL_PROVIDER_load' in libcrypto library.
Likely an incompatible SSL Interface. (err/ret=2/2)


Do I need to install OpenSSL 3.1 for this to work?

Thanks!

« Last Edit: May 24, 2023, 11:14:39 PM by martinp »

Mike King

  • Diamond Member
  • *****
  • Posts: 3830
  • Mike King
    • View Profile
    • BBSysco Consulting
Re: pvxplus 2023 - ubuntu 22 openssl not working?
« Reply #1 on: May 24, 2023, 05:29:31 PM »
Martin

There should be no need to override the SSL libraries.  We compiled PxPlus 2023 on Ubuntu 22 using the libraries it comes with.

PxPlus-2023 Web (Ver:20.00/UNIX-Linux-Ubuntu) Serno:2000-664-2181225
(c) Copyright 2005-2023 PVX Plus Technologies Ltd. (All rights reserved)
  Website: http://www.pvxplus.com
->"uname -a
Linux vm-ubuntu-22 5.19.0-41-generic #42~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Tue Apr 18 17:40:00 UTC 2 x86_64 x86_64 x86_64 GNU/Linux
->open (1) "[tcp]www.pvxplus.com;443;secure"
->print tcb("OpenSSL_Version")
OpenSSL 3.0.2 15 Mar 2022
->end
Mike King
President - BBSysco Consulting
eMail: mike.king@bbsysco.com

martinp

  • Silver Member
  • ***
  • Posts: 38
    • View Profile
Re: pvxplus 2023 - ubuntu 22 openssl not working?
« Reply #2 on: May 24, 2023, 08:00:24 PM »
Thanks Mike, Maybe my version of Ubunti 22 is not the same?

I am using Ubuntu 22.04 Server LTS

Welcome to Ubuntu 22.04.2 LTS (GNU/Linux 5.15.0-72-generic x86_64)

Linux art-orion 5.15.0-72-generic #79-Ubuntu SMP Wed Apr 19 08:22:18 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux


PxPlus-2023 Demo (Ver:20.00/UNIX-Linux-Ubuntu) Serno:2000-664-0799999
(c) Copyright 2005-2023 PVX Plus Technologies Ltd. (All rights reserved)
  Website: http://www.pvxplus.com
->open(1)"[tcp]www.pvxplus.com;443;secure"
Error #13: File access mode invalid
Last IO to [tcp]www.pvxplus.com;443;secure, channel 1
Unable to locate SSL library (libcrypto) (err/ret=2/2)

Mike King

  • Diamond Member
  • *****
  • Posts: 3830
  • Mike King
    • View Profile
    • BBSysco Consulting
Re: pvxplus 2023 - ubuntu 22 openssl not working?
« Reply #3 on: May 24, 2023, 10:37:39 PM »
You likely just need the openssl libraries.

Use apt-get to install libssl-dev
Mike King
President - BBSysco Consulting
eMail: mike.king@bbsysco.com

martinp

  • Silver Member
  • ***
  • Posts: 38
    • View Profile
Re: pvxplus 2023 - ubuntu 22 openssl not working?
« Reply #4 on: May 24, 2023, 11:14:28 PM »
Worked!  Thank you!