PxPlus User Forum

Twitter Twitter Twitter

Author Topic: *pdf* Utility in Pxplus 18.20  (Read 180 times)

JuanVelazquez

  • Member
  • **
  • Posts: 12
    • View Profile
*pdf* Utility in Pxplus 18.20
« on: May 24, 2022, 08:38:15 PM »
Hello.

I have recently gone from pxplus 11.50 to version 18.20, I have had a problem when generating reports with the *pdf* utility (open (1)"*pdf*....), when generating the pdf files the right margin is lost, losing part of the report information.

In the Pxplus 18.20 version, has any change been made in the handling of margins or the *pdf* utility?

Greetings

Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3594
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: *pdf* Utility in Pxplus 18.20
« Reply #1 on: May 24, 2022, 08:43:40 PM »
Here are a couple of things that could be causing the issue:

- Size of font (What font size did you set)
- Setting of 'HP' system parameter (Is it enabled / disabled)

Your old install may have set these different from the default.

JuanVelazquez

  • Member
  • **
  • Posts: 12
    • View Profile
Re: *pdf* Utility in Pxplus 18.20
« Reply #2 on: May 24, 2022, 08:51:21 PM »
Hi Mike.

Thanks for your prompt response, the 'HP' parameter is by default, the font used is Arial 10

Greetings

Mike King

  • Administrator
  • Diamond Member
  • *****
  • Posts: 3594
  • Mike King
    • View Profile
    • PVX Plus Technologies
Re: *pdf* Utility in Pxplus 18.20
« Reply #3 on: May 25, 2022, 10:30:31 AM »
I tried the following here using the following program:

0010 SET_PARAM 'HP'
0020 OPEN (1)"*pdf*;view"
0030 PRINT (1)'FONT'("Arial",-10),'DF',
0040 PRINT (1)"Version=",TCB(29),'LF'
0050 FOR n=1 TO 5
0060 FOR i=0 TO 100 STEP 10
0070 PRINT (1)@(i),STR(i),
0080 NEXT i
0090 PRINT (1)'LF',
0100 NEXT n


And didn't see any difference on what was on the PDF file (See attachment)

JuanVelazquez

  • Member
  • **
  • Posts: 12
    • View Profile
Re: *pdf* Utility in Pxplus 18.20
« Reply #4 on: June 03, 2022, 12:55:00 PM »
Thanks for the help, I have readjusted the margins of the document and it is working without problems.

Regards