PxPlus User Forum

Twitter Twitter Twitter

Recent Posts

Pages: 1 2 3 [4] 5 6 ... 10
31
Web Services / Setup EZWeb server on RedHat Linux 8.x Server
« Last post by nmartinez@bristolind.com on August 09, 2022, 01:04:03 PM »
Hi all,
This is our first time setting up an EZWeb server on a RedHat Linux 8.x server.  We are testing the unsecure connection with port 8080 and when we try to access it via http://192.168.77.201:8080, we get the error shown on the attached file.  We probably still need to do some additional configuration.  Does anyone know what additional steps we are missing?
Our goal for getting setting up this EZWeb server is to be able to integrated one application on our current custom ERP (written in PVXPLUS) to TULIP via (BI-DIRECTIONAL) API calls.
Thank you!



32
Programming / Re: Composite String Record behaviour in an object.
« Last post by Peter.Higgins on August 09, 2022, 12:55:29 PM »
Mike,
Its a typo and should be str(AAARecord.RoadsideAssistenceNumber$ or str(Phone$ 
The summary is in an Object, composite strings for AAA$ & AAARec$ work but AAARecord$ will not. 
AAA is a place holder for a number of file names fortunately all 3 letters. 
Please note on the system in question that AAARecord.RoadsideAssistenceNumber$ works in a run or called program just not in objects.
33
Programming / Re: Composite String Record behaviour in an object.
« Last post by Mike King on August 09, 2022, 12:43:27 PM »
Is it just a typo in what you posted or did you really mean

? str(AAARecord.RoadsideAssistenceNumber$:"xxx-xxx-xxxx")

and not

? str(AAA.RoadsideAssistenceNumber$:"xxx-xxx-xxxx")

Which was what you posted?
34
Programming / Composite String Record behaviour in an object.
« Last post by Peter.Higgins on August 09, 2022, 12:24:26 PM »
I use records frequently as object parameters and find the structure neither remains after the enter, or in a local variable.  So I must do the following in every method. Except I've found debugging that a variable of len 9 will not return data from a composite string although the structure is there. Note: I have not played with how long a variable still works.   Curious if I missed something in documentation,  if this is unusual  behavior, or just an object limitation?  version 2017 on Linux.

! Doesn't work
ENTER (FILEREC$),(FILEIOL$)
DIM AAARecord$:fileiol$
AAARecord$=FILEREC$
phone$=AAA.RoadsideAssistenceNumber$
? lst(iol(AAARecord$))  ! will show Structure. 
? str(AAA.RoadsideAssistenceNumber$:"xxx-xxx-xxxx")
   -   -   

! This works
ENTER (FILEREC$),(FILEIOL$)
DIM AAA$:fileiol$
AAA$=FILEREC$
phone$=AAA.RoadsideAssistenceNumber$
? str(phone$:"xxx-xxx-xxxx")
888-888-8888
35
Off Topic / Experienced developer available for work - once again!
« Last post by David Miller on August 07, 2022, 08:45:29 PM »
Once again due to corporate buyouts and reshuffles, I find myself looking for work,  I had been developing in PxPlus since 2006 through 2020 (laid off because of corporate maneuvering etc. etc.) and am experienced in coding and also developing in Nomads e.g.  I have also worked in Business Basic and Thoroughbred Basic since the early 90's. On the web end of things I have also developed in Javascript, VBScript, .asp and HTML.  I've taken training in other languages and am currently taking further education in Oracle SQL, some Linux etc.  After 2020 through till the present I've been working on another companies ERP system focusing on interfaces processing EDI PO imports.  I am currently looking for work so if you're interested then please contact me and we can go on from there.

Thanks - David Miller
36
Nomads / Re: Security property on folder tabs
« Last post by PMM_CAI on August 07, 2022, 01:30:08 PM »
My apologies. You're right; I should have said panel X has two tabs and it's X.1 that has the two controls plus the security. I will do a ticket.
37
Nomads / Re: Security property on folder tabs
« Last post by Jane Raymond on August 04, 2022, 02:37:10 PM »

Previously, Y and Z are on panel X (the main panel), but the security is on X.1, so I don't follow  why security is affecting controls on the main panel. But now Y and Z are on the first tab, so I'm a bit confused.

If you have some simplified panels that illustrate what you are attempting, it would be great if you set up a support ticket on our Helpdesk and upload the sample panels there and explain what is happening vs what you are expecting to happen.
38
Nomads / Re: Security property on folder tabs
« Last post by PMM_CAI on August 04, 2022, 01:54:09 PM »
Thanks Jane! So in my example... should I be thinking that it is the Y multi-line that is not behaving as it should? I.e. yes it's disabled when first drawn, but then I have code to enable all members of a particular group, of which Y and Z are part of said group. For USER (as well as MGR), Z enables, but Y stays disabled.

This was the behavior in my uber simplified test panel, as well as the existing FM panel. My test is a panel with two tabs, the first tab had multi-line Y and dropbox Z. I hit a button that does a call "*wingrp;Enable" for the only group that these two objects belong to. There are no other things, like dependencies, that might explain why Y stays disabled.   - Paula.
39
Nomads / Re: Security property on folder tabs
« Last post by Jane Raymond on August 04, 2022, 10:51:58 AM »
When a folder panel is drawn, the controls are disabled for view-only access. What happens after that would be dependent on your code enabling them programmatically, or the effect of a dependency.
(Note: This response is incorrect. It has been corrected in the Aug. 10 response.)
40
Programming / Re: Error 13 on [tcp] connection with secure
« Last post by michaelgreer on August 03, 2022, 03:08:38 PM »
Mike and Devon,

Thanks for your assistance and patience.  I am running windows where the issues are occurring. I did install the latest version of PxPlus and it had no issues.  I also do not find SSL installed on my machine.

Connected to the customer who is redhat, running pvx 12.50.  *No* issues, so this is done I guess.

Never mind on this --->  Seeing invalid key so staring in demo mode. One question. I have a PVXKEY set for all of my PxPlus instances.  When I launch the 2022 pxplus I expected to have an issue with that but it came up in Demo mode. How is it "ignoring" my PVXKEY env. variable?
Pages: 1 2 3 [4] 5 6 ... 10