PxPlus User Forum

Twitter Twitter Twitter

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Jeffrey Ferreira

Pages: [1] 2 3 ... 10
1
Programming / Re: Passing a COM Object to a CMD
« on: November 18, 2022, 10:33:25 AM »
Thank you - I will try it out.

2
Programming / Re: Passing a COM Object to a CMD
« on: November 18, 2022, 07:48:55 AM »
Hi Stéphane ,
I was hoping there was something that already existed. I should have looked harder. However when i run it it says pvxtlb.exe does not exist?  I'm running version 1710-001 on windows...should it be there?
thanks
jeff

3
Programming / Passing a COM Object to a CMD
« on: November 17, 2022, 05:06:39 PM »
Hi List
I was trying to do the following
def object excel_obj,"Excel.Application"

I then created a *cmd\PO to parse object and return values for troubleshooting...
if i do
call "*cmd\PO",excel_obj it works
but if i do

PO EXCEL_OBJ
i get an error 36 ..i don think it sees it as a numeric...i seem to remember something like *VARIANT

can anyone shed any light on this?

thanks
jeff

4
Programming / Re: Associative Arrays
« on: October 17, 2022, 11:32:11 AM »
Thanks Mike
that is exactly what i am looking for.

jeff

5
Programming / Associative Arrays
« on: October 17, 2022, 11:06:23 AM »
Hello All,

If I have a small associative array of items like this
INSTALL_ITEM_ARRAY["INS1"]=1
INSTALL_ITEM_ARRAY["INS2"]=1
INSTALL_ITEM_ARRAY["INS3"]=1

 If I check to see if item is in the array it adds that item to array with a value of 0.
Question -> Is there a way i can check the array without it adding it to array. Is this taking up room in memory ...
if i'm checking a few million invoices lines - i dont want to run into an error 31

I know i can use a memory file but the associative array is quite convenient.

thanks

jeff

6
Web Services / Re: EZWeb Server
« on: September 26, 2022, 02:59:28 PM »
Hi Mike

the program name is parts.pxp
i'm using http://localhost:8080/parts.pxp
i'm not using a query string at this time
it is an older version of pxplus 10.2

here is my program parts.pxp

0010 print (%PRINT_FN)"<html>"
0020 print (%PRINT_FN)"<head>"
0030 print (%PRINT_FN)"</head>"
0040 print (%PRINT_FN)"<body>"
0041 print (%PRINT_FN)"<h1>Hello Jeff</h1>"
0042 print (%PRINT_FN)"</body>"
0043 print (%PRINT_FN)"</html>"
0050 end

i'm pretty sure it is finding my program because in firefox here is what it shows on screen

[Pvxprg]�Ù���Õ�½�cai         ����������������������������������������c1’þ���������������X9�������Ù���Õ���½�������Ù��������������������������������������������������������������������������������������������������������������������������������������������€�'�   text/htmlÿ��
Ç$€&�<html>ÿ��Ç$€&�<head>ÿ��Ç$€&�</head>ÿ��(Ç$€&�<body>ÿ��)Ç$€&�<h1>Hello Jeff</h1>ÿ��*Ç$€&�</body>ÿ��+Ç$€&�</html>ÿ��2¦ÿ�ýè¦ÿ
%CONTENT_TYPE   %PRINT_FN���

7
Web Services / Re: EZWeb Server
« on: September 26, 2022, 02:04:29 PM »
Hi Mike when i do this it seems to go into the Downloads Folder and when i open it , it is my program but in an encrypted format [pvxprg]

8
Web Services / EZWeb Server
« on: September 26, 2022, 12:23:17 PM »
Hello List,
I was able to get ezweb server running and rendering static html pages.
when i use print(%PRINT_FN) - it seems to return a file
i'm trying to create a dynamic html page on the fly

so if user goes to localhost:8080/part=A123

i want to return an html page but i want to modify some of the info...
does anyone know how i can do that....
thanks
jeff

9
Language / *plus\web\request
« on: September 07, 2022, 04:50:17 PM »
Hi All,
I am running pxplus 13.1
I have been using *plus\web\request with a fair amount of success with both http and https sites.
Recently a web service provider made some changes. I can no longer connect to certain https urls  using "*plus web request" ->  msg(-1) = "Unable to connect securely"
But i can connect using powershell and postman.

Does anyone have any thoughts suggestions?
i can rewrite my program to use powershell but i would prefer not to if i dont have to.

thanks

jeff

p.s. the web service is to get an access token.

10
Web Services / Re: *web/email not working for smtp.office365.com
« on: June 30, 2022, 05:00:51 PM »
Hi All,

I keep hearing people mention that Microsoft is doing away with basic Authentication for emailing thru an App an instead we will need to use something called OAuth. But then i read that there will be an exception for SMTP. I heard the date October 1, 2022 mentioned.  Can anyone shed any light on this? I'm concerned that our Office 365 email integrations could potentially stop working.

thanks
jeff

11
Language / Trapping for Escape Key
« on: May 18, 2022, 10:58:45 AM »
Hello,

Is there any way to trap for the ESC key being hit. I tried _EOM$ and ctl but i cannot seem to distinguish it from clicking the X-Close .
or would i need to modify *UCK

thanks

jeff

12
Programming / Re: providex.usr - Auto Create
« on: April 29, 2022, 04:57:03 PM »
Thanks Mike - i will give it a try.

13
Programming / providex.usr - Auto Create
« on: April 29, 2022, 03:57:47 PM »
Hello List,

In old pxplus. Is there a way i could automatically create the providex.usr file.
A client is looking for me to make a wizard to create a USER by just answering a few questions.
i should have posted this in "Language"

Thank

jeff

14
Programming / Re: Converting HTML to PDF
« on: April 26, 2022, 09:50:48 AM »
Devon, i tried that (wkhtmltopdf) and it worked perfect.. thank you

15
Programming / Re: Converting HTML to PDF
« on: April 26, 2022, 09:45:58 AM »
i did see that. I might try it. thank you

Pages: [1] 2 3 ... 10